The notification delivery issue has been fully resolved.
At this time, no further action is required. If you have any questions or need assistance, TigerConnect Customer Support is available through the following channels:
Phone: 650-564-4722 (or Premium Support Toll-Free Number)
TigerConnect App: Direct message to TigerConnect Admin
Posted Dec 18, 2025 - 12:41 PST
Monitoring
We have successfully rolled back the recent changes and are seeing notification delivery return to normal. Our team is continuing to monitor the system closely to ensure stability.
TigerConnect Customer Support is available for any follow ups at the following channels: Phone: 650-564-4722(or Premium Support Toll-Free Number) Email: prosupport@tigerconnect.com TigerConnect App: direct message to TigerConnect Admin
Posted Dec 18, 2025 - 11:41 PST
Identified
We do not believe the reported iOS notification issues are related to this incident and are reviewing those cases separately.
For Android devices, our team has identified the root cause. We are currently assessing the full impact. As a precaution, we have begun rolling back the changes made yesterday.
We will provide another update within one hour. Thank you for your patience.
TigerConnect Customer Support is available for questions or issue handling through the following channels: Phone: 650-564-4722(or Premium Support Toll-Free Number) Email: prosupport@tigerconnect.com TigerConnect App: direct message to TigerConnect Admin
Posted Dec 18, 2025 - 11:10 PST
Update
We are still actively investigating the intermittent notification delivery issue affecting all device types. Some users may continue to experience delayed or missing notifications while our team works to identify the root cause and restore normal service as quickly as possible.
We appreciate your continued patience and will provide another update within the next hour.
TigerConnect Customer Support remains available for questions or issue assistance through the following channels: Phone: 650-564-4722 (or Premium Support Toll-Free Number) Email: prosupport@tigerconnect.com
TigerConnect App: Direct message to TigerConnect Admin
Posted Dec 18, 2025 - 10:10 PST
Investigating
We are currently experiencing sporadic delays in notifications delivery, and in some cases notifications may not be received at all across all device types. Our team is actively investigating, receiving, and triaging the issue to restore normal service as quickly as possible.
We will provide another update within one hour. Thank you for your patience.
TigerConnect Customer Support is available for questions or issue handling through the following channels: Phone: 650-564-4722(or Premium Support Toll-Free Number) Email: prosupport@tigerconnect.com TigerConnect App: direct message to TigerConnect Admin