Message Delivery Latency
Incident Report for TigerConnect
Resolved
We noticed some issues affecting our system's performance and have taken action to fix them. Everything is now back to normal.

If you experience any issues with the TigerConnect application, please contact TigerConnect Support:
- Email: prosupport@tigerconnect.com
- Phone: (650) 564-4722
Posted Jul 25, 2024 - 12:36 PDT
Investigating
Advisory: TigerConnect is observing minor message delivery latency (5-9sec) on mobile and web/desktop platform. Investigation under way.

Please subscribe to this page for further updates.
Posted Jul 25, 2024 - 12:13 PDT
This incident affected: Messaging Services.